Réencodage RV9=>Xvid
Forum DivX de Ri4m - Encoder et réencoder les videos - DivX - XviD - RV10 - RV9 - VP6 - VP7

Bienvenue invité ( Connexion | Inscription )

> Charte du forum

Réglement intérieur du forum : La loi interdit la récupération "sauvage" des films sur internet, n'est tolérée que la "copie de sauvegarde personnelle". TOUTE mention à une activité "hors la loi" sera sanctionnée directement par une fermeture du sujet voire un avertissement ...

Ripp-it Te@m

2 Pages V   1 2 >  
Reply to this topicStart new topic
Sharp
posté 08/10/2008 21:13 Bookmark and Share
Message #1


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 08/10/2008
Membre no 47.811



Bonjour,

J'ai découvert votre programme il y a peut et je tiens avant toute chose à vous féliciter du boulot.

Mais malgré votre travail, j'ai un bug beuh.gif

J'ai des mkv de 175Mo, contenant une piste video RV9, 2 piste audio ogg, 2 piste sous titre srt. Je voudrais les reconvertir pour des raisons de compatibilités avec mon lecteur de salon. A la sortie, je souhaite avoir soit un Xvid son MP3, soit un OGM (cela dépend de la qualité de sortie), et une piste sous titre srt à part. Car mon lecteur supporte les format OGM et sous titre en fichiers séparé.

Le problème intervient au moment de ré-encoder le RV9, en OGM ou AVI avec une taille préciser de 172 Mo pour le fichier final, je me retrouve avec un fichier de 24Go....
J'ai essayer d'installer plein de codecs ou outils différents, Real Player; de chercher sur le forum ou ailleurs... Mais rien n'y fait.

Merci pour votre aide.

Sharp
Aller en haut de la page
 
+Citer le message
YannBresil
posté 09/10/2008 01:38 Bookmark and Share
Message #2


Ri(n)oModo
Icône de groupe

Groupe : Super Modérateurs
Messages : 7.488
Inscrit : 18/10/2003
Lieu : Manaus, au centre de l'Amazonie
Membre no 443



Bienvenue pointu,
Mets l'analyse du film et la vérification de ta config.
Aller en haut de la page
 
+Citer le message
Sharp
posté 09/10/2008 12:16 Bookmark and Share
Message #3


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 08/10/2008
Membre no 47.811



(YannBresil @ jeudi 09 octobre 2008 à 02:38) *
Mets l'analyse du film et la vérification de ta config.


L'analyse du film
1145kbps / 172Mo / Codec RV40 / 25.0000 fps / 31550 f / 640x416
no audio

Deux questions me viennent:
- 31550 f = 31550 frames?
- Il n'y a pas moyen de rajouter directement l'audio pendant le premier encodage de la vidéo? Cela éviterais des pertes de qualités en les re-ré-encodant, non? Pouvoir rentrer l'audio et la vidéo, et que leur ré-encodage ce fasse en une opération.

Vérification de la config
Hum, hum....
Je n'avais jamais regardé ça, il semblerais qu'il ne trouve pas beaucoup de codecs...

Ripp-it_AM [ 5.0.3b - Avisynth 2.5.7 / K-lite ]
****************************************************

[ Video ]
DivX : - [ INTROUVABLE ]
Xvid : - [ INTROUVABLE ]
X264 (cli) : OK [ svn-440 ]
X264 (vfw) : - [ INTROUVABLE ]
VP6 : - [ INTROUVABLE ]
VP7 : - [ INTROUVABLE ]
DivX 3.11 : - [ INTROUVABLE ]
Quicktime Alternative : - [ INTROUVABLE ]
ffdshow : - [ INTROUVABLE ]
----------------------------------------------------
[ Audio ]
CORE - AAC Codec : - [ INTROUVABLE ]
LAME - MP3 Codec : OK [ 0.0.9.0 ]
AC3 Filter : - [ INTROUVABLE ]
Oggcodecs : - [ INTROUVABLE ]
OggDs : - [ INTROUVABLE ]
----------------------------------------------------
[ Miscs ]
PepsiCoda (Encoding) ON
Pack PSP/iPod/3GP : - [ INTROUVABLE ]
Ripp-it Codec Pack : - [ INTROUVABLE ]
DVDFab Platinum : - [ INTROUVABLE ]
DVDFab Decrypter : - [ INTROUVABLE ]
Web Browser : C:\program files\Internet Explorer\iexplore.exe
----------------------------------------------------
[ AVISYNTH ]
AVIsynth.dll OK [ 2.5.6.0 ]
C:\Program Files\AviSynth 2.5\plugins\*.*
- colors_rgb.avsi OK
- DirectShowSource.dll OK
- TCPDeliver.dll OK
----------------------------------------------------
[ Matroska (MKV) ]
Matroska Splitter : - [ INTROUVABLE ]
MKVtoolnix : OK [ v2.3.0 ]
MUX MKV : C:\Program Files\MKVtoolnix\MKVmerge.exe : OK
DEMUX MKV GUI : C:\Program Files\MKVtoolnix\MKVEXTRACTGUI.exe : OK
MKVINFOS : C:\Program Files\MKVtoolnix\mkvinfo.exe : OK
DEMUX MKV : C:\Program Files\MKVtoolnix\mkvextract.exe : OK
----------------------------------------------------
[ Real Video (RV9/RV10 - .rmvb) ]
Real Alternative : - [ INTROUVABLE ]
CODEC RV9/10 : - [ INTROUVABLE ]
ENCODE RV40 : C:\Program Files\Ripp-it_AM\PRODUCER\producer.exe : OK [ 10.0.0.74 ]
----------------------------------------------------
[ MPEG 1/2 - (VCD/SVCD/DVD - .mpg .mp2) ]
ENCODE MPEG : C:\Program Files\Ripp-it_AM\TMPGEnc-2.525.64.184-EN-Free\TMPGEnc.exe : OK [ 2.525.64.184 ]
----------------------------------------------------
[ NERO Burning Rom ]
NERO BURNING ROM: : - [ INTROUVABLE ]
NERO COMMAND : : - [ INTROUVABLE ]
----------------------------------------------------

** END OF FILE - 02192 bytes


Votre avis docteur?!? guix_hum.gif
Aller en haut de la page
 
+Citer le message
bd9
posté 09/10/2008 16:23 Bookmark and Share
Message #4


Producteur
Icône de groupe

Groupe : Modérateurs
Messages : 5.384
Inscrit : 15/04/2006
Lieu : toulouse
Membre no 18.057



tu as le pack codecs ripp-it sur la page de téléchargement.
Desinstalle bien les autres packs avant si besoin est.
Aller en haut de la page
 
+Citer le message
YannBresil
posté 10/10/2008 01:12 Bookmark and Share
Message #5


Ri(n)oModo
Icône de groupe

Groupe : Super Modérateurs
Messages : 7.488
Inscrit : 18/10/2003
Lieu : Manaus, au centre de l'Amazonie
Membre no 443



installe déjà le quicktime alternative et le codec xvid du pack de codec, puis reposte une analyse du film.
Aller en haut de la page
 
+Citer le message
Sharp
posté 20/10/2008 17:41 Bookmark and Share
Message #6


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 08/10/2008
Membre no 47.811



Salut,
J'ai installé le pack de codecs de Ripp-it

J'ai deux problèmes:
1- J'ai plus de sous titre qui s'affichent dans le player que j'utilise, que dois-je installer pour pouvoir voir mes subs?

2- La reconvertion marche mais c'est au niveau des frames que ça plante.
Le mkv indique 29.97fps, et le fichier rmvb qui sort 25fps. Je pense que c'est la source...
Car ensuite tout marche sauf au moment de muxer en un fichier avi. Le son est décalé, j'ai essayer de remettre les frames avec l'option "décalage de son" avant, après muxer, mais rien n'y fait.
Il faudrait pouvoir conserver le fps de base dès le demuxage, je pense...

Merci pour les réponses cling1.gif
Aller en haut de la page
 
+Citer le message
YannBresil
posté 21/10/2008 01:14 Bookmark and Share
Message #7


Ri(n)oModo
Icône de groupe

Groupe : Super Modérateurs
Messages : 7.488
Inscrit : 18/10/2003
Lieu : Manaus, au centre de l'Amazonie
Membre no 443



1. vobsub
2. dans le réencodage tu peux forcer le framerate. le rmvb est connu pour être mauvais sur cette information
Aller en haut de la page
 
+Citer le message
Sharp
posté 21/10/2008 17:20 Bookmark and Share
Message #8


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 08/10/2008
Membre no 47.811



Salut,

Pour l'affichage de sous titre c'est réglé, c'est con mais c'était pas très pratique na1.gif

Pour le fps je comprends pas exactement se que je dois faire. Le changement de fps se fait directement à l'extraction du rmvb... Pas au réencodage... Tu me conseils de démuxer le rvmb "par défaut" (sans rien toucher) et au réencodage passer du rmvb 25fps à du Xvid (ou peut inporte) 29.97fps?
Je ne perdrais rien a faire mkv en 29.97 => rmvb 25 puis Xvid 29.97 ?
Il me semble avoir déjà essayer ça dans un élan de "je vais y arriver!"...
Mais au cas ou je re-test.

Sharp
Aller en haut de la page
 
+Citer le message
Sharp
posté 21/10/2008 21:19 Bookmark and Share
Message #9


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 08/10/2008
Membre no 47.811



Re,

Alors l'analyse du mkv donne 30fps, par contre l'analyse approfondie en donne 29,97....
En tout cas j'ai essayé avec ces 2 fps de ré-encoder le rmvb en Xvid. Aucun des deux chiffres ne marche le son reste toujours décalé. Je ne comprends vraiment pas pourquoi en sachant qu'il n'y a que le rmvb qui change et passe en 25fps mon œil de newbie se tourne de son côté pour chercher le bug....
Ai-je tort, est-ce que j'oublie quelque chose... Et surtout si c'est ça, je fais comment?!? wink.gif

Merci!
Sharp
Aller en haut de la page
 
+Citer le message
YannBresil
posté 21/10/2008 23:43 Bookmark and Share
Message #10


Ri(n)oModo
Icône de groupe

Groupe : Super Modérateurs
Messages : 7.488
Inscrit : 18/10/2003
Lieu : Manaus, au centre de l'Amazonie
Membre no 443



ne touche pas à la video, fais un stretch de la bande son dans le module de décalage son
Aller en haut de la page
 
+Citer le message
Sharp
posté 22/10/2008 16:02 Bookmark and Share
Message #11


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 08/10/2008
Membre no 47.811



Salut,

Alors j'ai essayer pas mal de chose, avec ce menu là et rien n'a été concluant. Par contre je me suis rendu compte d'un truc qui me fait rester sur mes positons...
Dans le réencodage du .rmvb, deux problèmes naissent:
1- La vidéo est redimensionné, et pas qu'un peu.. A ma grande surprise je ne m'en suis pas rendu compte plus tôt, surement le nez trop dedans..
2- La vidéo fait la bonne durée par contre ça fin est noir pendant quelques minutes. Mon explication logique serais que le fps n'est pas respecté pendant le re-encodage, donc "on comble avec du vide"

Je me penche sur les options de ré-encodage. Mais je trouve ça bizarre Ripp-It reconnait vraiment mal mon rmvb

Sharp
Aller en haut de la page
 
+Citer le message
Sharp
posté 22/10/2008 20:22 Bookmark and Share
Message #12


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 08/10/2008
Membre no 47.811



Re,
Alors quelques petites avancées sur mes problèmes...

Pour le redimensionnement, l'analyse RippIt du mkv donne une mauvaise dimension, pour le rmvb, pareille. Alors en ré-encodage, l'erreur se poursuit. C'est limite logique... J'ai trouver le menu pour changer ça dans RippIt par contre je ne trouve pas le moyen de connaitre la résolution d'un fichier .rmvb ou.mkv. Même Gspot ne donne rien.
Avec cette info je pourrait forcer le bon fonctionnement.

Et ma supposition extrême : Si ça plante au niveau de la dimension, ça plante peut être aussi au niveau des fps... Et là même méthode...

J'attends vos avis et conseils.
je dois dire que là, je me sens complètement dépassé...
Sharp
Aller en haut de la page
 
+Citer le message
YannBresil
posté 23/10/2008 00:43 Bookmark and Share
Message #13


Ri(n)oModo
Icône de groupe

Groupe : Super Modérateurs
Messages : 7.488
Inscrit : 18/10/2003
Lieu : Manaus, au centre de l'Amazonie
Membre no 443



le rmvb est très mauvais pour ça.
Pour la diemnsion et le framrate, ouvre le fichier original avec mpc par exemple, dans les propriétés il te donnera les informations.
Aller en haut de la page
 
+Citer le message
Sharp
posté 23/10/2008 19:03 Bookmark and Share
Message #14


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 08/10/2008
Membre no 47.811



Salut,

C'est bien la galère ^^

Alors mpc j'avais déjà essayé il m'indique la même chose que Ripp-It... Je vais finir par croire que c'est ma vue qui change entre 2 vidéos!
Si quelqu'un pourrait m'indiquer alors, la valeur d'un fps japonais, et comment réglé la résolution en 4/3 sur Ripp-it. Je vais essayer à l'œil, ça peut marcher...

Mais c'est quand même bizarre que RippIt me réencode de la vidéo en me laissant du noir à la fin...

Donc pour résumer toujours pareille: Je nage!
Sharp
Aller en haut de la page
 
+Citer le message
YannBresil
posté 24/10/2008 00:34 Bookmark and Share
Message #15


Ri(n)oModo
Icône de groupe

Groupe : Super Modérateurs
Messages : 7.488
Inscrit : 18/10/2003
Lieu : Manaus, au centre de l'Amazonie
Membre no 443



montre l'analyse de film par riam et ce qu'en dit mpc
Aller en haut de la page
 
+Citer le message
Sharp
posté 24/10/2008 08:11 Bookmark and Share
Message #16


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 08/10/2008
Membre no 47.811



(YannBresil @ vendredi 24 octobre 2008 à 01:34) *
montre l'analyse de film par riam et ce qu'en dit mpc



L'analyse du mkv par Riam

1276 kbps - 192 mo - 00.21.03.296 - 5 tracks
Vidéo_t1 : 1276 kbps - 183 mo - Codec RV40 - 29.9700 fps - 37861 f - 640x416
Audio_t2 : 57 kbps - 9 mo - Codec OGG - 2 ch - 48000 hz

L'analyse du mkv par MPC

Video: RealVideo 4 640x416 (4:3) 30.00fps [Video]
Audio: Vorbis (deprecated) 48000Hz stereo 104Kbps [Audio 664841663]



L'analyse du rmvb par Riam

1144 kbps - 172 mo - 00.21.02.000
Vidéo_t1 : 1144 kbps - 172 mo - Codec RV40 - 25.0000 fps - 31550 f - 640x416
-- no audio --

L'analyse du rmvb par MPC

Video: RealVideo 4 640x416 (4:3) 30.00fps 1140Kbps [Output 00 (Video)]
Aller en haut de la page
 
+Citer le message
rol
posté 27/10/2008 20:26 Bookmark and Share
Message #17


Admin
Icône de groupe

Groupe : Admin
Messages : 32.122
Inscrit : 12/05/2003
Lieu : DivX ou XviD
Membre no 2



On peut supposer que le fps est du 29.97 ou 23.97
Aller en haut de la page
 
+Citer le message
Sharp
posté 28/10/2008 15:09 Bookmark and Share
Message #18


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 08/10/2008
Membre no 47.811



Salut,

Pas bête le coup du fps en 23.97. ça marche!
Pour le son quand je ré-encode le ogg en mp3, ça plante encore, le mp3 obtenu fait bien la même durée que le ogg mais il y a 1min40 de silence à la fin. Du coup je reste sur de l'ogm, pas de réencodage audio et tout est impec.

Par contre j'ai toujours le bug de la résolution. 640x416 comme indiqué, n'est pas la bonne résolution je pencherai plus à vue de nez pour du 544x416.
Je change ça dans le menu "Prévisualisation" dans "Réencoder une vidéo" sur RippIt et alors que tout marchait bien avant que j'ai ré-encodé le même fichier, une erreur apparait sur virtualdub. "Video Compression error: The source image format is not acceptable. (error code -2)" et pour la deuxieme passe c'est "may be corrupted data"
Le fichier n'est pas corrompu puisque c'est le même que j'ai déjà ré-encodé en essayant avec 23.97fps. Je suis sûr que l'erreur vient du fait que je change la résolution....
Des idées..?

Merci de l'attention,
Sharp.
Aller en haut de la page
 
+Citer le message
rol
posté 29/10/2008 00:14 Bookmark and Share
Message #19


Admin
Icône de groupe

Groupe : Admin
Messages : 32.122
Inscrit : 12/05/2003
Lieu : DivX ou XviD
Membre no 2



As tu une erreur dans la prévisualisation ?
Aller en haut de la page
 
+Citer le message
Sharp
posté 29/10/2008 01:05 Bookmark and Share
Message #20


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 08/10/2008
Membre no 47.811



Non. Aucune tout se passe bien jusqu'à ce que VirtualDub se lance. C'est là seulement que les erreurs apparaissent.
Aller en haut de la page
 
+Citer le message

Réencodage RV9=>Xvid


2 Pages V   1 2 >
Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 

Modes d'affichage: Standard ·


Regrouper

> Discussions similaires à la discussion "Réencodage RV9=>Xvid"

Sujet Réponses
Reencodage vidéo 14
Reencodage de bluray 2
Réencodage ne démarre pas 5
Réencodage 7
réencodage flv 7
Réencodage H264 vers divx 3
réencodage fichier audio aac en mp3 impossible !!!!! 32
réencodage mkv avi , suppression du générique de fin 1
réencodage video 16
réencodage impossible avec deux fichiers .avi [résolu] [Réglé] 19

> Sujets récents

Sujets
test2
Why Ripp-it(ing) After Me and why Ripp-it(ing) For Me ? So then what's the third Ripp-it(ing) part ?
test
Reencodage vidéo
Windows10 et RIAM
améliorer le son d'un divx
Compression d'un MKV sans perte de qualité ?
Titres sur le DVD vs épisodes du menu
Intégrer des chaps dans un mkv ?
Film à retrouver
message d'erreur
Telechargement RI4M id et mot de passe
Arrêt
Avantage d'utilisation de Viabox
Le président Chirac agit pour l'Histoire !!!!

RSS Nous sommes le : 20/11/2019 07:11
Ripp-It - Le site - Glossaire Audio Vidéo - Versions Rippit - Présentation - Tutoriaux divx - Télécharger Ripp-It - Ripper DVD - Annuaire liens en dur
Forum Vidéo DivX - Ripp-It - Le site - Le glossaire - Les versions - Présentation - Tutoriaux divx - Télécharger Ripp-It - Ripp-It - Plan du site
Forum PSP - Forum iPod - Forum Mobile - Forum cinéma - Ripit4ME - Contact

Foot
Forum Ri4m™ © 2019 Ri4m™ - Enregistré à la CNIL sous le numéro 1081457