Ri4m : problème VirtualDub / Avisynth
Forum DivX de Ri4m - Encoder et réencoder les videos - DivX - XviD - RV10 - RV9 - VP6 - VP7

Bienvenue invité ( Connexion | Inscription )

> Charte du forum

Réglement intérieur du forum : La loi interdit la récupération "sauvage" des films sur internet, n'est tolérée que la "copie de sauvegarde personnelle". TOUTE mention à une activité "hors la loi" sera sanctionnée directement par une fermeture du sujet voire un avertissement ...

Ripp-it Te@m

 
Reply to this topicStart new topic
Amour
posté 05/05/2009 à 11:56 Bookmark and Share
Message #1


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 9
Inscrit : 05/05/2009
Membre no 52.653



Bonjour

Je suis sur Windows 7 build 7100 (la release candidate), sur un système neuf. J'ai installé aujourd'hui divers logiciels en dernière version (Ri4m, ffdshow, haali media splitter, mkvtoolnix, real alternative, virtualdub, avisynth).

Je souhaite transformer une vidéo .mkv en .avi pour la faire fonctionner avec freeplayer. Je l'ai démuxée avec mkvextract et j'ai donc ceci :
* le .mkv original
* le .rmvb de la piste vidéo
* le .ogg de la piste audio
* le .srt de la piste sous-titres

Ré-encodage audio
1) Je choisis « ré-encoder audio » dans le menu de ripp-it
2) Je sélectionne le fichier .ogg
3) Je choisis un encodage mp3 et je clique sur « ré-encoder le son »
J'ai alors deux erreurs au niveau de VirtualDub :
Avisynth read error: CAVIStreamSynth: System exception - Access Violation at 0x2173b35, reading from 0x0
An exception occurred in module 'KERNELBASE'.

Ré-encodage vidéo
1) Je choisis « ré-encoder un film » dans le menu de ripp-it
2) Je sélectionne le fichier .rmvb
3) Je choisis un encodage ffdshow:xvid et une seule passe, puis je clique sur « lancer le réencodage »
J'ai alors une erreur au niveau de VirtualDub :
An out-of-bounds memory access (access violation) occurred in module 'virtualdubmod'.

Voici ma config :
Code
Ripp-it_AM  [ 5.0.3b - Avisynth 2.5.7 / K-lite ]
****************************************************

[ Video ]
DivX :              - [ INTROUVABLE ]
Xvid :              - [ INTROUVABLE ]
X264 (cli) :         OK [ svn-440 ]
X264 (vfw) :          - [ INTROUVABLE ]
VP6 :              - [ INTROUVABLE ]
VP7 :              - [ INTROUVABLE ]
DivX 3.11 :          - [ INTROUVABLE ]
Quicktime Alternative :  - [ INTROUVABLE ]
ffdshow :         OK [ 1.0 ]
----------------------------------------------------
[ Audio ]
CORE - AAC Codec :      - [ INTROUVABLE ]
LAME - MP3 Codec :     OK [ 0.0.9.0 ]
AC3 Filter :          - [ INTROUVABLE ]
Oggcodecs :          - [ INTROUVABLE ]
OggDs :         OK [ 0.9.9.5 ]
----------------------------------------------------
[ Miscs ]
PepsiCoda (Encoding)    OFF
Pack PSP/iPod/3GP :     - [ INTROUVABLE ]
Ripp-it Codec Pack :     OK [ v 4.2.6 ]
DVDFab Platinum :      - [ INTROUVABLE ]
DVDFab Decrypter :      - [ INTROUVABLE ]
Web Browser :         C:\program files\Internet Explorer\iexplore.exe
----------------------------------------------------
[ AVISYNTH ]
AVIsynth.dll         OK [ 2.5.8.5 ]
C:\Program Files+\AviSynth\plugins\*.*
- colors_rgb.avsi OK
- DirectShowSource.dll OK
- TCPDeliver.dll OK
----------------------------------------------------
[ Matroska (MKV) ]
Matroska Splitter :     OK
MKVtoolnix :         OK [ v2.7.0  ]
MUX MKV :         C:\Program Files+\MKVtoolnix\mkvmerge.exe : OK
DEMUX MKV GUI :     C:\Program Files+\MKVtoolnix\MKVEXTRACTGUI.exe : OK
MKVINFOS :         C:\Program Files+\MKVtoolnix\mkvinfo.exe : OK
DEMUX MKV :         C:\Program Files+\MKVtoolnix\mkvextract.exe : OK
----------------------------------------------------
[ Real Video (RV9/RV10 - .rmvb) ]
Real Alternative :     OK [ 1.9.0 ]
CODEC RV9/10 :         OK (Alternative)
ENCODE RV40 :         C:\Program Files+\Ripp-it_AM\PRODUCER\producer.exe : OK [ 10.0.0.74 ]
----------------------------------------------------
[ MPEG 1/2 - (VCD/SVCD/DVD - .mpg .mp2) ]
ENCODE MPEG :          :  - [ INTROUVABLE ]
----------------------------------------------------
[ NERO Burning Rom ]
NERO BURNING ROM:      :  - [ INTROUVABLE ]
NERO COMMAND :          :  - [ INTROUVABLE ]
----------------------------------------------------

** END OF FILE - 02086 bytes

Miniature(s) jointe(s)
Image attachée
Image attachée
 

Image(s) jointe(s)
Image attachée
 
Aller en haut de la page
 
+Citer le message
rol
posté 05/05/2009 à 12:01 Bookmark and Share
Message #2


Admin
Icône de groupe

Groupe : Admin
Messages : 32.087
Inscrit : 12/05/2003
Lieu : DivX ou XviD
Membre no 2



Salut,

en ce qui concerne l'erreur Avisynth :
Citation
Avisynth read error: CAVIStreamSynth: System exception - Access Violation at 0x2173b35, reading from 0x0
An exception occurred in module 'KERNELBASE'.


Il faut installer Avisynth 2.5.6a

Quel version de Windows 7 utilises-tu ? x86 ou x64 ?
Aller en haut de la page
 
+Citer le message
Amour
posté 05/05/2009 à 12:05 Bookmark and Share
Message #3


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 9
Inscrit : 05/05/2009
Membre no 52.653



Oui, merci pour le lien de la FAQ, je viens de lire ce point, tout à la fin !
Je suis en 32 bits, je n'ai rien en 64 bits.
Je vais tester l'ancien avisynth (qui date de 2005...) et vous donner des nouvelles.

Ce message a été modifié par Amour - 05/05/2009 à 12:10.
Aller en haut de la page
 
+Citer le message
rol
posté 05/05/2009 à 12:08 Bookmark and Share
Message #4


Admin
Icône de groupe

Groupe : Admin
Messages : 32.087
Inscrit : 12/05/2003
Lieu : DivX ou XviD
Membre no 2



Ok, j'attends tes résultats cling1.gif
Aller en haut de la page
 
+Citer le message
Amour
posté 05/05/2009 à 12:23 Bookmark and Share
Message #5


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 9
Inscrit : 05/05/2009
Membre no 52.653



J'ai aussi renommé dossiers et fichiers pour qu'il n'y ai pas d'espaces ou caractères spéciaux (mais ça n'a rien changé à l'affaire).

Avec l'ancien Avisynth, j'ai maintenant un simple plantage (dans les deux situations, audio et vidéo) :
VirtualDub has stopped working

Pour l'audio, d'abord un fichier « $$audio0$$.wav » vide est créé. Puis il est renommé « film_out.mp3 ». Il fait 0 octet.
Pour la vidéo, rien n'est créé.

Voici le debug :
Code
** Ri4m [ 5.0.3b - Avisynth 2.5.7 / K-lite ] DEBUG **********************************

05/05 12:22:22 input : e:\temp\austin.rmvb
05/05 12:22:22 867 kbps - 563 mo - 01.30.50.960
05/05 12:22:22 Vidéo_t1 : 867 kbps - 563 mo - Codec RV40 - 25.0000 fps - 136274 f - 640x272
05/05 12:22:22 -- no audio --
05/05 12:22:22 output : E:\temp\OUT_austin.avi
05/05 12:22:22 codec : ffdshow - [ 739 kbps ]
05/05 12:22:22 no audio
** AVI - VirtualDubMod - CBR 1 pass
05/05 12:22:23 start
05/05 12:22:23 --- Aripp-it.AVS ---
05/05 12:22:23    # **** Ripp-it & AVIsynth 2.5x script **** pass 2+
05/05 12:22:23     LoadPlugin("C:\PROGRA~3\RIPP-I~1\dlls\undot.dll")
05/05 12:22:23    LoadPlugin("C:\PROGRA~3\RIPP-I~1\dlls\DirectShowSource.dll")
05/05 12:22:23     Source="e:\temp\austin.rmvb"
05/05 12:22:23    Largeur=640
05/05 12:22:23    Hauteur=272
05/05 12:22:23    ratio  =2.352941
05/05 12:22:23    vratio =2.352941
05/05 12:22:23    Crop_g=0
05/05 12:22:23    Crop_d=0
05/05 12:22:23    Crop_h=0
05/05 12:22:23    Crop_b=0
05/05 12:22:23    Indice=0.169807
05/05 12:22:23     Video=DirectShowSource( Source, fps=25.000000)
05/05 12:22:23    Video=KillAudio(video)
05/05 12:22:23    Video=ConvertToYV12(Video)
05/05 12:22:23    Video=BilinearResize(Video, Largeur, Hauteur)
05/05 12:22:23 ---
05/05 12:22:28 E:\temp\OUT_austin_.AVI : no

** DEBUG END **********************************


Ce message a été modifié par Amour - 05/05/2009 à 12:25.
Aller en haut de la page
 
+Citer le message
rol
posté 05/05/2009 à 12:32 Bookmark and Share
Message #6


Admin
Icône de groupe

Groupe : Admin
Messages : 32.087
Inscrit : 12/05/2003
Lieu : DivX ou XviD
Membre no 2



Ah ben oui mais là tu essayes de convertir un rmvb... Il est lisible dans Windows Media Player ?

Tu utilises ffdshow pour le réencoder ??
Aller en haut de la page
 
+Citer le message
Amour
posté 05/05/2009 à 13:04 Bookmark and Share
Message #7


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 9
Inscrit : 05/05/2009
Membre no 52.653



Oui, mon .rmvb est lisible dans WMP puisque j'ai installé Real Alternative pour ça.

Heu, je tente d'utiliser Ri4m pour réencoder, et jusque là je n'ai eu aucun succès ni avec la vidéo, ni avec l'audio : c'est virtualdub qui plante. J'ai donné tous les détails plus haut.

J'aimerais simplement trouver un moyen de rendre mes films compatibles avec freeplayer. Le codec de ré-encodage est donc libre, tant qu'il y en a un qui fonctionne.

Ce message a été modifié par Amour - 05/05/2009 à 13:06.
Aller en haut de la page
 
+Citer le message
Amour
posté 05/05/2009 à 13:33 Bookmark and Share
Message #8


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 9
Inscrit : 05/05/2009
Membre no 52.653



J'ai essayé de suivre au plus près ce tuto :
http://www.ripp-it.com/tutos/reencodage_mkv.php5

Voici donc à quoi ressemble mes réglages, en image. À noter que je n'ai pas de bouton orange dans la colonne de gauche pour les formats DivX/Xvid.
Miniature(s) jointe(s)
Image attachée
 
Aller en haut de la page
 
+Citer le message
rol
posté 05/05/2009 à 13:42 Bookmark and Share
Message #9


Admin
Icône de groupe

Groupe : Admin
Messages : 32.087
Inscrit : 12/05/2003
Lieu : DivX ou XviD
Membre no 2



Installe le codec DivX ou XviD et reessaye avec des réglages "standards" (ffdshow est chelou pour encoder yahoo1.gif )
Aller en haut de la page
 
+Citer le message
Amour
posté 05/05/2009 à 16:47 Bookmark and Share
Message #10


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 9
Inscrit : 05/05/2009
Membre no 52.653



J'ai essayé. Ca ne résoud rien.

Il y a plantage systématique de VirtualDubMod 1.5.10.2 Fr - [ARipp-it.avs].

Il fallait s'en douter, car un codec vidéo ne va pas miraculeusement résoudre un problème qui se produit aussi avec l'audio.
Aller en haut de la page
 
+Citer le message
rol
posté 05/05/2009 à 17:30 Bookmark and Share
Message #11


Admin
Icône de groupe

Groupe : Admin
Messages : 32.087
Inscrit : 12/05/2003
Lieu : DivX ou XviD
Membre no 2



Le problème c'est le rmvb surtout. Essaye de réencoder une vidéo contenant du DivX et du MP3 cling1.gif
Aller en haut de la page
 
+Citer le message
shmft
posté 31/01/2014 à 18:43 Bookmark and Share
Message #12


Spectateur
Icône de groupe

Groupe : Membres
Messages : 22
Inscrit : 15/03/2008
Membre no 37.412



Bonjour,
Plateforme: XP SP3, CM Gigabyte, Proco AMD Phenom II X4.
Certes le sujet est ancien, mais le pb ressurgit quand il veut et où il veut. Alors si cela pouvait servir à d'autres...
Après 4 années d'usage de RIAM sans trop de galère, je viens d'avoir le pb décrit en intro (avisynth read error) lors de la conversion d'une vidéo au format DVD enregistrée sur un enregistreur de salon.
J'ai désinstallé mon Avisynth (2.5) et j'ai installé Avisynth 2.5.6a; j'ai éliminé tous les noms de répertoire et fichier qui contenaient des caractères accentués.
Résultat: plus de plantage.
Crdlt.

Ce message a été modifié par shmft - 31/01/2014 à 18:46.
Aller en haut de la page
 
+Citer le message
SG1
posté 01/02/2014 à 10:36 Bookmark and Share
Message #13


Producteur
Icône de groupe

Groupe : Rédacteurs
Messages : 6.251
Inscrit : 08/10/2004
Lieu : Un coin perdu du Gers (32)
Membre no 4.657



Bonjour,

Merci pour le retour d'info (même si le sujet date, en effet yahoo1.gif)

AviSynth doit effectivement être installé dans sa version de base proposé par Ri4m...
Toute version supérieure à la 2.5.6 peut, en effet, poser problème...

@+
Aller en haut de la page
 
+Citer le message
newsoftpclab
posté 02/02/2014 à 13:40 Bookmark and Share
Message #14


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 14
Inscrit : 31/03/2013
Membre no 57.802



Citation (SG1 @ samedi 01 février 2014 à 10:36) *
Bonjour,

Merci pour le retour d'info (même si le sujet date, en effet yahoo1.gif)

AviSynth doit effectivement être installé dans sa version de base proposé par Ri4m...
Toute version supérieure à la 2.5.6 peut, en effet, poser problème...

@+

pour toutes ces info.Cela va m'aider aussi.
Aller en haut de la page
 
+Citer le message
allermuller123
posté 08/06/2014 à 08:04 Bookmark and Share
Message #15


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 1
Inscrit : 06/06/2014
Membre no 58.016



bonjour , très contente de chercher ce forum et votre thème ,c'est très utile et efficace pour mon travail maintenant ,,merci bcp ..... happy.gif happy.gif happy.gif
Aller en haut de la page
 
+Citer le message

Ri4m : problème VirtualDub / Avisynth


Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 

Modes d'affichage: Standard ·


Regrouper

> Discussions similaires à la discussion "Ri4m : problème VirtualDub / Avisynth"

Sujet Réponses
Probleme pour encoder un DVD sur Ihone 3GS !! 9
problème d'encodage SubRip 5
Problème de police dans les sous-titres 38
Problème de Qualité 10
Problème avec Ripp-It 6
probléme d'encodage 4
probléme de config de Ripp-it 1
Ri4m détecté comme malware par MSE 1
Probleme création vidéo wmv 13
probleme de son absent qui ne veut pas se ripper 4

> Sujets récents

Sujets
Why Ripp-it(ing) After Me and why Ripp-it(ing) For Me ? So then what's the third Ripp-it(ing) part ?
Reencodage vidéo
Windows10 et RIAM
améliorer le son d'un divx
Compression d'un MKV sans perte de qualité ?
Titres sur le DVD vs épisodes du menu
Intégrer des chaps dans un mkv ?
Film à retrouver
message d'erreur
Telechargement RI4M id et mot de passe
Arrêt
Avantage d'utilisation de Viabox
Le président Chirac agit pour l'Histoire !!!!
Message erreur lors de l'installation d'un logiciel...
RIAM a cessé de fonctionner......

RSS Version bas débit Nous sommes le : 23/03/2019 à 23:00
Ripp-It - Le site - Glossaire Audio Vidéo - Versions Rippit - Présentation - Tutoriaux divx - Télécharger Ripp-It - Ripper DVD - Annuaire liens en dur
Forum Vidéo DivX - Ripp-It - Le site - Le glossaire - Les versions - Présentation - Tutoriaux divx - Télécharger Ripp-It - Ripp-It - Plan du site
Forum PSP - Forum iPod - Forum Mobile - Forum cinéma - Ripit4ME - Topvideo - Contact

Foot
Utilisation de la bande passante
Forum Ri4m™ © 2013 Ri4m™ - Enregistré à la CNIL sous le numéro 1081457