avisynth et Windows 7 x64
Forum DivX de Ri4m - Encoder et réencoder les videos - DivX - XviD - RV10 - RV9 - VP6 - VP7

Bienvenue invité ( Connexion | Inscription )

> 


 
Reply to this topicStart new topic
Ueno
posté 03/04/2012 à 23:47 Bookmark and Share
Message #1


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 2
Inscrit : 03/04/2012
Membre no 57.429



Bonjour !

Je parcours des dizaines de forums depuis quelques jours sans parvenir à résoudre mon problème, j'espère trouver ici quelqu'un qui saura m'aider (je précise que j'ai d'ores et déjà recherché, en vain, des réponses sur ce forum ^^).

J'encode des vidéos à l'aide d'avisynth et de VirtualDub depuis pas mal de temps déjà et je n'ai jamais eu de souci majeur. Mais jusqu'ici, j'étais sous Windows XP, et je viens de changer de PC et de passer du même coup à Windows 7 (64bits), et là, c'est le drame !

En effet, une fois le nécessaire installé (avisynth + plugins et autres filtres + VD + avidemux au cas où...), impossible ne serait-ce que d'ouvrir le moindre fichier .avs ! Et les filtres ne semblent pas être en cause puisque j'ai tenté la même chose avec un script des plus basiques (à savoir un simple chargement d'un fichier .d2v).

VirtualDub (quelle que soit la version, j'en ai testé plusieurs pour être sûr) freeze d'entrée de jeu. Je n'ai aucun message d'erreur d'aucune sorte, il plante, point. Et il ne me reste plus qu'à le fermer.
J'ai voulu tenter la même manoeuvre avec Avidemux et avsproxy. Lors du chargement du script dans ce dernier, il s'arrête presque aussitôt, juste après avoir chargé avisynth.dll. Voici très exactement ce qui s'affiche dans les "détails" :

AvsSocket Proxy, derivated from avs2yuv by Loren Merritt Avs2YUV 0.24 ADM_1.2
Loading Avisynth.dll
Avisynth.dll loaded
Env created


Et il s'arrête là, obligé de faire un ctrl+alt+suppr pour en sortir.

Enfin, par acquis de conscience, j'ai tenté également d'ouvrir les scripts avs avec meGUI, le résultat est le même : plantage direct ouin.gif

La conclusion qui s'impose pour le moment serait qu'a priori, avisynth et Windows 7 x64 ne font pas bon ménage (j'avais eu l'occasion de tester sur Seven 32bits il y a un an et ça avait fonctionné si mes souvenirs sont bons). Or j'ai pu voir, ici ou sur d'autres forums, que beaucoup parviennent à encoder des scripts avs avec ce même OS sans rencontrer cette difficulté. Autrement dit, ça devrait marcher ! Sauf que ce n'est pas le cas... :'(

Pour l'instant, j'ai trouvé une solution de "remplacement" un peu tirée par les cheveux, qui est de lancer mes encodages dans un Windows XP virtuel, mais évidemment, ça n'utilise qu'une infime partie des capacités du processeur, or c'est essentiellement pour ça que je l'ai acheté (j'avais des traitements horriblement longs pour certaines vidéos qui demandent un filtrage très lourd). Donc je cherche désespérément quelle peut être la raison qui empêche tous logiciels d'encodage d'ouvrir ces fichus scripts.

Voilà, j'espère avoir été clair dans mes explications, et qu'une âme charitable sera en mesure de m'aider parce que là, je ne sais plus quoi faire à part emmener mon PC à Lourdes en priant pour un miracle ! an_ouarf.gif
Aller en haut de la page
 
+Citer le message
SG1
posté 04/04/2012 à 10:59 Bookmark and Share
Message #2


Producteur
Icône de groupe

Groupe : Rédacteurs
Messages : 6.240
Inscrit : 08/10/2004
Lieu : Un coin perdu du Gers (32)
Membre no 4.657



Bonjour,

Bienvenue sur le forum de Ri4m...

Je n'utilise plus Seven depuis quelques temps, mais je vais tenter de t'aiguiller...

Pour installer quelque chose sur Seven, il est souvent préférable de désactiver l'UAC.

Dans ce tuto, http://forum.ripp-it.com/Installer-RI4m-su...its-t23401.html
tu as l'explication pour l'installation de Ri4m sur Seven.
Ce n'est pas ton cas, mais je suppose que ça peut être identique pour l'install d'AviSynth (Vu que Ri4m installe AviSynth).

Ensuite, il est souvent nécessaire de faire fonctionner les logiciels en mode Administrateur.

Soit clic droit sur le programme ou le raccourci, puis Exécuter en tant qu'Administrateur

Ou également, Clic droit --> Propriétés --> Onglet Compatibilité --> Exécutez ce programme en tant qu'administrateur

Quelques infos ici :
http://www.clubic.com/windows-os/windows-7...teur-13048.html


@+

Ce message a été modifié par SG1 - 04/04/2012 à 10:59.
Aller en haut de la page
 
+Citer le message
Ueno
posté 04/04/2012 à 20:16 Bookmark and Share
Message #3


Ouvreur
Icône de groupe

Groupe : Membres
Messages : 2
Inscrit : 03/04/2012
Membre no 57.429



Hello !

Merci pour ta réponse. Hélas, cela ne change rien au problème sad.gif

J'ai bien désactivé l'UAC (merci pour cette info en tout cas, ça devenait particulièrement lourd ce truc ! ^^), tout désinstallé et réinstallé + exécuté en tant qu'admin mais le résultat reste le même.

J'ai tenté aussi un nettoyage du registre avec CCleaner, au cas où il subsisterait des petites merdes ici ou là, mais non, rien à faire...
Aller en haut de la page
 
+Citer le message
SG1
posté 05/04/2012 à 09:02 Bookmark and Share
Message #4


Producteur
Icône de groupe

Groupe : Rédacteurs
Messages : 6.240
Inscrit : 08/10/2004
Lieu : Un coin perdu du Gers (32)
Membre no 4.657



Bonjour,

Attention peut-être à la version de AviSynth... Toutes ne sont pas forcément compatibles, et la dernière version n'est pas forcément la meilleure...
A ce niveau là, je pense que Léon pourra t'en dire plus quand il passera par là...

Concernant l'UAC, je te conseille quand même de la remettre après installation...

@+
Aller en haut de la page
 
+Citer le message

avisynth et Windows 7 x64


Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 

Modes d'affichage: Standard ·


Regrouper

> Discussions similaires à la discussion "avisynth et Windows 7 x64"

Sujet Réponses
Windows10 et RIAM 4
Avisynth Multithread 5
windows seven 3
Avisynth open failure 16
Windows Seven dans tous ses états... 22
avisynth open fail 0
avisynth open failure 2
Avisynth 5
Windows 7 beta et ripp-it (ne fonctionne pas) 6
Avisynth error 3

> Sujets récents

Sujets
Windows10 et RIAM
améliorer le son d'un divx
Compression d'un MKV sans perte de qualité ?
Titres sur le DVD vs épisodes du menu
Intégrer des chaps dans un mkv ?
Film à retrouver
message d'erreur
Telechargement RI4M id et mot de passe
Arrêt
Avantage d'utilisation de Viabox
Le président Chirac agit pour l'Histoire !!!!
Message erreur lors de l'installation d'un logiciel...
RIAM a cessé de fonctionner......
Probleme pour encoder un DVD sur Ihone 3GS !!
recherche peintre batiment sur Marseille

RSS Version bas débit Nous sommes le : 23/09/2018 à 10:51
Ripp-It - Le site - Glossaire Audio Vidéo - Versions Rippit - Présentation - Tutoriaux divx - Télécharger Ripp-It - Ripper DVD - Annuaire liens en dur
Forum Vidéo DivX - Ripp-It - Le site - Le glossaire - Les versions - Présentation - Tutoriaux divx - Télécharger Ripp-It - Ripp-It - Plan du site
Forum PSP - Forum iPod - Forum Mobile - Forum cinéma - Ripit4ME - Topvideo - Contact

Foot
Utilisation de la bande passante
Forum Ri4m™ © 2013 Ri4m™ - Enregistré à la CNIL sous le numéro 1081457