Version imprimable du sujet

Cliquez ici pour voir ce sujet dans son format original

Forum Ripp-it After Me _ Support et Assistance Technique _ Astuce décalage audio...

Écrit par : SG1 15/01/2008 10:17

Bonjour, an_coucou.gif

Après discussion entre Modérateurs/Redacteurs, je vous propose une petite astuce pour corriger un décalage audio...

...Astuce que j'ai expérimenté 3 fois avec succès pour corriger un décalage audio d'une vidéo AVI/DivX.

Cette astuce n'ayant apparemment pas été tentée, je vous la propose. Testez-là et dites-moi si ça marche chez vous !

Sur les films « Next » et « Pirates des Caraïbes 3 », je me suis retrouvé avec un décalage audio... ce qui n'est pas rare, j'en conviens !

Mais plutôt que de me prendre la tête à tenter de corriger le décalage, j'ai réalisé un nouvel encodage (toujours à partir du rip du DVD) avec modification du Script AVS.

Donc, édition du script AVS dans la fenêtre de prévisualisation. [N°1 sur la capture d'image]
(Ouvrez la fenêtre de Prévisualisation de Ri4m et cliquez sur « Editer le Script »

Vous obtenez donc un fichier texte ressemblant à ceci :

# **** Ripp-it & AVIsynth 2.5x script **** pass 1

LoadPlugin("C:\PROGRA~1\RIPP-I~1\dlls\undot.dll")
LoadPlugin("C:\PROGRA~1\RIPP-I~1\dlls\VSFilter.dll")
LoadPlugin("C:\PROGRA~1\RIPP-I~1\dlls\MPEG2Dec3.dll")

# Video codec : DivX
# Video bitrate : 1239966

Source="H:\TRAITE~1\Encoder\PIRATE~1\VTS_04_1.d2v"
Largeur=720
Hauteur=400
ratio =1.800000
vratio =1.800000
Crop_g=0
Crop_d=0
Crop_h=0
Crop_b=0
Indice=0.172218

Video=mpeg2Source(Source)
Video=Undot(Video)
Video=BilinearResize(Video, Largeur, Hauteur)
Video=TextSub(Video, "H:\Traitement\Encoder\Pirates des Caraibes 3\04-Francais4 Wide Letterbox _Ripp-it.ssa")

Return(Video)


Si vous avez déjà regardé de près un fichier AVS (AviSynth) créé lors de l'encodage avec Ri4m, vous pourrez constater que le fichier de la « Passe 2 » comporte des lignes supplémentaires...

Trois lignes justes avant « Return(Video) » qui permettent de rajouter l'audio...

Audio=WAVsource("H:\TRAITE~1\Encoder\PIRATE~1\audio0.wav")
Audio=DelayAudio(Audio, 0.000000)
Video=AudioDub(Video, Audio)


Donc, dans votre fichier AVS en cours, vous ajoutez vous-même ces trois lignes et vous obtiendrez ceci :

# **** Ripp-it & AVIsynth 2.5x script **** pass 1

LoadPlugin("C:\PROGRA~1\RIPP-I~1\dlls\undot.dll")
LoadPlugin("C:\PROGRA~1\RIPP-I~1\dlls\VSFilter.dll")
LoadPlugin("C:\PROGRA~1\RIPP-I~1\dlls\MPEG2Dec3.dll")

# Video codec : DivX
# Video bitrate : 1239966

Source="H:\TRAITE~1\Encoder\PIRATE~1\VTS_04_1.d2v"
Largeur=720
Hauteur=400
ratio =1.800000
vratio =1.800000
Crop_g=0
Crop_d=0
Crop_h=0
Crop_b=0
Indice=0.172218

Video=mpeg2Source(Source)
Video=Undot(Video)
Video=BilinearResize(Video, Largeur, Hauteur)
Video=TextSub(Video, "H:\Traitement\Encoder\Pirates des Caraibes 3\04-Francais4 Wide Letterbox _Ripp-it.ssa")

Audio=WAVsource("H:\TRAITE~1\Encoder\PIRATE~1\audio0.wav")
Audio=DelayAudio(Audio, 0.000000)
Video=AudioDub(Video, Audio)

Return(Video)


Attention, ne vous trompez pas sur le chemin du fichier Wave. Le chemin est identique à celui de la source indiqué plus haut dans le script. Le nom du fichier Wave, même s'il n'est pas encore créé est toujours le même : audio0.wav

Si vous avez constaté un décalage audio, c'est que vous avez déjà réalisé un encodage.
Ouvrez ce fichier AVI dans VirtualdubMPEG2 (ou virtualdub) et cliquez sur « Fichier - Informations de fichier ». L'analyse va indiquer la longueur du fichier vidéo et celle du fichier audio...

Relevez la différence et rapportez-la sur la ligne : Audio=DelayAudio(Audio, 0.000000)

Dans mon cas, c'était un décalage de 600 ms (millisecondes) trop tôt. Ce qui nous donne :

Audio=DelayAudio(Audio, 0.600000)

Dans le cas ci-dessus, le chiffre est donc positif. Si le son arrive en retard, il faudra mettre un chiffre négatif. Exemple : Audio=DelayAudio(Audio, -0.600000) !

Et donc le fichier complet sera :

# **** Ripp-it & AVIsynth 2.5x script **** pass 1

LoadPlugin("C:\PROGRA~1\RIPP-I~1\dlls\undot.dll")
LoadPlugin("C:\PROGRA~1\RIPP-I~1\dlls\VSFilter.dll")
LoadPlugin("C:\PROGRA~1\RIPP-I~1\dlls\MPEG2Dec3.dll")

# Video codec : DivX
# Video bitrate : 1239966

Source="H:\TRAITE~1\Encoder\PIRATE~1\VTS_04_1.d2v"
Largeur=720
Hauteur=400
ratio =1.800000
vratio =1.800000
Crop_g=0
Crop_d=0
Crop_h=0
Crop_b=0
Indice=0.172218

Video=mpeg2Source(Source)
Video=Undot(Video)
Video=BilinearResize(Video, Largeur, Hauteur)
Video=TextSub(Video, "H:\Traitement\Encoder\Pirates des Caraibes 3\04-Francais4 Wide Letterbox _Ripp-it.ssa")

Audio=WAVsource("H:\TRAITE~1\Encoder\PIRATE~1\audio0.wav")
Audio=DelayAudio(Audio, 0.600000)
Video=AudioDub(Video, Audio)

Return(Video)


A noter que ainsi, les fichiers AVS des Passes 1 et 2 seront totalement identiques.
Vous pourrez vérifier après avoir réalisé l'encodage.

Vous avez fait les modifications ?
Alors fermez le fichiers AVS qui va vous demander d'enregistrer les modifications... Acceptez bien sûr !

Vous constaterez alors que le Script AVS a été « Figé » par Ri4m (la ligne « Figer Script » juste en dessous du bouton « Editer le script » est cochée)...
Ceci afin d'éviter toute modification ultérieure non souhaitée. [N°2 sur la capture d'image]

Il est donc très important d'avoir déjà réalisé les modifications éventuelles de taille ou de crop... parce que maintenant, Niet !!!

Votre encodage peut maintenant être réalisé... En respectant une dernière chose :

Le script AVS étant figé, vous devrez encoder votre film en deux étapes.

Cliquez d'abord sur le bouton « Faire AUDIO » [N°3 sur la capture d'image]
Quand l'audio est fait, vous pourrez cliquer sur « Faire VIDEO » [N°4 sur la capture d'image]

Un message vous dira que l'audio doit déjà être fait... (ce qui est le cas !)

Voilà, dans quelques heures, vous aurez un beau film tout neuf sans décalage...
...heuuu, normalement !
Bon, evidemment ça a fonctionné plusieurs fois chez moi. Ce qui ne veux pas dire que ça fonctionnera tout le temps et chez tout le monde.

L'explication de l'astuce est un peu longue, mais l'astuce elle-même est en fait ultra simple.

De ce fait, je suis d'ailleur étonné que personne n'y ait pensé avant !

Bon encodage ! cling.gif

@+

PS : Pour une meilleure compréhension et suite à quelques demandes de précisions, j'affiche ici deux captures d'images...




Écrit par : YannBresil 17/01/2008 01:55

excellente astuce, bien expliquée!

Post-itéex

Écrit par : SG1 17/01/2008 13:50

Bonjour,

Merci Yann de l'avoir "épinglée" (en bon français an_ouarf.gif ) !

@+

Écrit par : leon1789 19/01/2008 00:38

Bonsoir,

Sur les film « Next » et « Pirates des Caraïbes 3 », je me suis retrouvé avec un décalage audio...

(juste pour savoir) Est-ce que le ripp s'est passé normalement pour ces deux films ?

Écrit par : MiKL47 19/01/2008 23:43

ras cling1.gif je tente et je vous fais signe !

Écrit par : MiKL47 20/01/2008 01:11

ou la, alors je n'arrive pas a trouver la diiference entre l'audio et la video (longueur)

"Ouvrez ce fichier AVI dans VirtualdubMPEG2 (ou virtualdub) et cliquez sur « Fichier - Informations de fichier ». L'analyse va indiquer la longueur du fichier vidéo et celle du fichier audio...

Relevez la différence et rapportez-la sur la ligne : Audio=DelayAudio(Audio, 0.000000)

Dans mon cas, c'était un décalage de 600 ms (millisecondes) trop tôt. Ce qui nous donne :

Audio=DelayAudio(Audio, 0.600000)"

Voila ce que ca donne pour moi

http://forum.ripp-it.com/redirect.php?url=http%3A%2F%2Fimg237.imageshack.us%2Fimg237%2F9783%2Fscreenry7.jpg

Je dois mettre quoi comme valeur ??? (dans le tuto ci dessus, tu parles en milisecondes.... ?! moi je trouve 1seconde 48 de decalage, comment je trouve la bonnevaleur pour ma video ????)


Autre chose encore, je préfere garder le son en original 5.1, donc en ac3... Cette astuce pour le décalage fonctionne t'elle quand meme?

Ne faut il pas modifier quelque chose dans la ligne du script ???

Merci aga.gif

Écrit par : SG1 20/01/2008 16:05

Bonjour,

(leon1789 @ samedi 19 janvier 2008 à 00:38) *

Sur les film « Next » et « Pirates des Caraïbes 3 », je me suis retrouvé avec un décalage audio...

(juste pour savoir) Est-ce que le ripp s'est passé normalement pour ces deux films ?


Oui, sans aucun problème...

...mais ne me demande pas pourquoi il y avait un décalage ! euh.gif

Je pense que ce genre de problème dépend plus de la machine et des logiciels installés que réellement du DVD lui-même !

@+

Écrit par : SG1 20/01/2008 16:25

Bonjour,

(MiKL47 @ dimanche 20 janvier 2008 à 01:11) *
ou la, alors je n'arrive pas a trouver la diiference entre l'audio et la video (longueur)

Voila ce que ca donne pour moi...

D'après ce que je peux voir sur ta capture, le vidéo fait 41'29,48"
et l'audio 41'28,00"
Donc la bande audio est plus courte de 1 seconde et 48 centièmes.


Je dois mettre quoi comme valeur ??? (dans le tuto ci dessus, tu parles en milisecondes.... ?! moi je trouve 1seconde 48 de decalage, comment je trouve la bonnevaleur pour ma video ????)

Quand tu visionnes ta vidéo (décalée), est-ce que le décalage perçu est approximativement de 1,5 secondes ?

Si le décalage correspond à la différence relevée dans Virtualdub, il te faudra mettre
Audio=DelayAudio(Audio, 1.480000)"


Attention tout de même, le différence relevée entre l'audio et la vidéo ne veux pas forcément dire que ton décalage est identique. Il peut être inférieur... donc visionnes ta vidéo décalée pour tenter de déterminer le plus précisément possible le décalage.


Autre chose encore, je préfere garder le son en original 5.1, donc en ac3... Cette astuce pour le décalage fonctionne t'elle quand meme?

Ça, je n'en ai pas la moindre idée, je n'encode qu'en MP3 à 128 kbps parce que j'estime que cela est largement suffisant... De toute façon, à part quelques heures perdues en encodage, tu ne risques pas grand chose à essayer... cling.gif

Ne faut il pas modifier quelque chose dans la ligne du script ???

La ligne que l'on modifie dans le script AVS n'est pas tributaire du format audio, donc normalement...

Merci aga.gif


Fais savoir ensuite si ça fonctionne...
Bon courage

@+

Écrit par : leon1789 22/01/2008 23:24

Hi,

(leon1789 @ samedi 19 janvier 2008 à 00:38) *
(juste pour savoir) Est-ce que le ripp s'est passé normalement pour ces deux films ?

(SG1 @ dimanche 20 janvier 2008 à 16:05) *
Oui, sans aucun problème...
...mais ne me demande pas pourquoi il y avait un décalage ! euh.gif

Tu m'as donné envie de voir ça : j'ai choisi "Pirates...III".
Et ben pour commencer, j'ai dû batailler fort pour réaliser le ripp... Il est loin d'être commode pour mon pc !
J'ai ensuite séparé les pistes audio et vidéo : maintenant j'encode chacune d'elles. (je n'ai pas constaté de décalage)

(SG1 @ dimanche 20 janvier 2008 à 16:05) *
Je pense que ce genre de problème dépend plus de la machine et des logiciels installés que réellement du DVD lui-même !

Oui, c'est possible.

Écrit par : SG1 23/01/2008 15:52

Bonjour,

(leon1789 @ mardi 22 janvier 2008 à 23:24) *
Tu m'as donné envie de voir ça : j'ai choisi "Pirates...III".
Et ben pour commencer, j'ai dû batailler fort pour réaliser le ripp... Il est loin d'être commode pour mon pc !

Petite info : Dans mon cas, le rip avait été fait avec DVDFab !

J'ai ensuite séparé les pistes audio et vidéo : maintenant j'encode chacune d'elles. (je n'ai pas constaté de décalage)

Ah bon ? Perso, je n'ai jamais tenté de séparer audio et vidéo avant encodage... Mais bon, les habitudes de chacun !
...Le principal c'est d'arriver à un bon résultat !


@+

Écrit par : leon1789 25/01/2008 20:51

(SG1 @ mardi 15 janvier 2008 à 10:17) *
(...)
Source="H:\TRAITE~1\Encoder\PIRATE~1\VTS_04_1.d2v"
Largeur=720
Hauteur=400
(...)

C'est bien ton script d'encodage de Pirates de Caraïbes 3 (Jusqu'au bout du monde) ?

Je viens de voir ça : c'est bizarre, ta résolution est 720x400 : tu encodes avec les bandes noires ? (parce que l'image réelle est au format 2.35, et s'encode en 720x304).

Écrit par : SG1 26/01/2008 17:20

Bonjour,

(leon1789 @ vendredi 25 janvier 2008 à 20:51) *
Je viens de voir ça : c'est bizarre, ta résolution est 720x400 : tu encodes avec les bandes noires ? (parce que l'image réelle est au format 2.35, et s'encode en 720x304).


Oui, toujours... ça me permet d'avoir un affichage correct et modifiable sur mon lecteur TviX (HDD Multimédia).

@+

Écrit par : leon1789 27/01/2008 20:30

ok aga.gif

Écrit par : SG1 28/01/2008 09:09

Bonjour,

Actualisation !

Rajout de deux images dans le message de départ (en haut) pour une meilleure compréhension suite à la demande de quelques personnes...

@+

Écrit par : Numaro 29/01/2008 09:18

Bonjour, an_coucou.gif

Novice en la matière il y a encore un mois, votre forum m'a tout simplement formé pour comprendre le divx dans toutes ses formes.

Bref tout cela pour dire que cette astuce fonctionne à merveille et que l'explication des manoeuvres est impécable.

Encore bravo pour cette trouvaille qui pour moi résoud une fois pour toute ces fameux problèmes de décalage audio qui commencaient sérieusement à m'énerver. evil.gif

Un grand grand merci.

A bientôt... cling.gif

Christophe (GRENOBLE)

Écrit par : SG1 29/01/2008 09:51

Bonjour,

Bienvenue sur le forum de Ri4m...

...et très heureux de voir que ça ne marche pas que chez moi ! cling.gif

@+

Écrit par : YannBresil 30/01/2008 01:05

Numaro, je vois que tu es fan d'un film culte ici

Écrit par : sykes2477 30/01/2008 11:19

C'est vrai ça, ni Davcop ni moi n'avons remarqué... Heureusement que Yann veille... aga.gif

Écrit par : Numaro 31/01/2008 09:01

Salut à tous,

C'est vrai que cette machine à toujours été un rêve de gosse...! J'ai jamais eu les moyens pour me l'offrir, le littre de plutonium chez Total est bien trop cher...!!! an_what.gif

Enfin bon, je suis au bureau, faudrait peut-être que j'bosse moi !

Allez, je vous souhaite une bonne journée et un bon week !

Bye...! an_ouarf.gif

Écrit par : SG1 01/02/2008 08:47

Bonjour,

(Numaro @ jeudi 31 janvier 2008 à 09:01) *
C'est vrai que cette machine à toujours été un rêve de gosse...! J'ai jamais eu les moyens pour me l'offrir, le littre de plutonium chez Total est bien trop cher...!!! an_what.gif

T'as raté le dernier épisode... elle utilise des peaux de bananes et de la vieille bière... an_ouarf.gif

(Numaro @ jeudi 31 janvier 2008 à 09:01) *
Enfin bon, je suis au bureau, faudrait peut-être que j'bosse moi !

Fais gaffe, le patron est juste derrière toi... evil.gif $$$.gif hem.gif

@+

Écrit par : leon1789 09/04/2008 15:58

Question : est-ce que VirtualDub ne serait pas sujet à créer des décalages audios ???

Écrit par : SG1 11/04/2008 14:29

Bonjour,

(leon1789 @ mercredi 09 avril 2008 à 16:58) *
Question : est-ce que VirtualDub ne serait pas sujet à créer des décalages audios ???


Justement, je me pose de plus en plus de questions...
...y compris pour Ri4m via DVDDecrypter

Un ami rippe beaucoup de films depuis très longtemps et a toujours utilisé Neodivx 9.2...

...il n'a jamais eu de décalage audio !?!

Je pense qu'il sera nécessaire de regarder ce problème de plus près.

@+

Écrit par : leon1789 11/04/2008 15:06

Ah, je suis content que le doute naisse aussi en toi... car comme tu le sais (je vous l'ai assez répété cling1.gif ), ça fait bien longtemps que je n'ai eu de décalage audio (peut-être 2 ou 3 soucis sur environ 150 encodages).

C'est effectivement un problème à regarder de près. C'est pour ça que je faisais le sondage http://forum.ripp-it.com/index.php?showtopic=17960&hl=

Écrit par : SG1 09/05/2008 09:46

Bonjour,

Oooppsss !

J'avais pas fait attention à ta réponse...

En fait, j'utilsais avant NeoDivX 9.2 ou DivX vidéo Duplicator (mais de toute façon, c'est le même, puisque les droits du premier ont été vendu pour créer le second...)

Et j'ai découvert et donc utilisé Ri4m pour une seule raison...

?

?

?

Le sous-titrage...

Je n'ai jamais trouvé d'autres softs qui reconnaissent correctement les sous-titres.

Et donc, j'espère que ce problème de décalage audio sera corrigé avec la prochaine verison de Ri4m...

Rol, c'est à toi !!!!! gniark.gif

@+

Écrit par : beuz29 09/05/2008 10:32

moi personnellement je n'ai jamais de décalage audio....

Écrit par : SG1 09/05/2008 10:53

Bonjour,

(beuz29 @ vendredi 09 mai 2008 à 11:32) *
moi personnellement je n'ai jamais de décalage audio....


Avec Ri4m ?

@+

Écrit par : beuz29 09/05/2008 11:12

oui

Écrit par : SG1 09/05/2008 19:06

Bonjour,

Quelques titres de films ou j'ai eu des décalages...

- Dead or Alive : 4000 millisecondes
- xXx - The next level : 11.400 millisecondes
- Ratatouillle : 1000 millisecondes
- Ma sorcière bien-aimée : 11.229 millisecondes
- Pirates des Caraïbes 3 : 600 millisecondes
- Harry Potter 5 : 12.840 millisecondes

Et j'arrête là... ces dernier temps, c'est la poisse !

Heureusement, ce sont des décalages simples (non progressif).

Et je les corrige facilement selon ma méthode, au départ de l'encodage !

@+

Écrit par : leon1789 09/05/2008 19:26

aaaa.gif ben effectivement, ce ne sont pas des petits décalages !!

Écrit par : micjul 09/05/2008 19:49

Il y en a c'est bien plus aga.gif
J'ai encodé un film ce week-end ... 41,5 secondes d'avance vidéo .. mais en constant ...
Bon en 4 coup j'ai trouvé le bon timing..

Écrit par : fandjo 05/07/2008 20:52

Tiens tiens... j'etait justement en train de me dire ça... peut etre que tout nos problêmes de decalages viennent de VDB et RI4M (c'est pareil) ...je croit que je vais investir dans un soft payant gloups3.gif

Écrit par : SG1 16/07/2008 10:54

Bonjour,

(fandjo @ samedi 05 juillet 2008 à 21:52) *
Tiens tiens... j'etait justement en train de me dire ça... peut etre que tout nos problêmes de decalages viennent de VDB et RI4M (c'est pareil) ...je croit que je vais investir dans un soft payant gloups3.gif


Si tu en trouves un payant, non professionnel, qui peut faire tout ce que fait Ri4m, je veux bien revenir au cathéchisme... mrgreen2.gif

@+

Écrit par : Jojo's 25/04/2011 08:55

Yeah! Merci pour les infos tongue.gif

Propulsé par Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)